?

Log in

No account? Create an account
 
 
12 March 2007 @ 04:17 pm
Asian Characters  
Hi guys (again), haha.

As some of you may know ... I'm making an Oguri Shun fansite, but that's not really the point. I was wondering how you get the Asian characters (such as Oguri Shun's name) to appear properly on a site?

For me, I use Notepad and I simply type it in, or I copy and paste it. Then I would save it as a UTF-8 file. It works ... only if the browser's character encoding is set on Unicode. When I go to other people's websites, other people's Asian characters show up properly, but when I go to my own sites, the characters don't show up and I have to manually change the encoding! (Case in point: check out the discography section, it's a mess).

If anybody could help point me in the right direction, that would be helpful!
Tags:
 
 
Current Mood: creativecreative
Current Music: ANNA inspi' NANA - I'm Addicted To You
 
 
 
Tehrin: sexybacktehrin on March 13th, 2007 12:12 am (UTC)
Hmm, usually I put the encoding in the file's header.

But it won't work period if the person's computer doesn't have the language pack installed. <3 OSX for having it automatically. I *think* (i'm not too sure on this) but if you use a converter, it should make it come out as unicode, and you can just plop it in there, and I think it will work for most people. But it's not really useful doing it that way when you have files that you want to go back and edit, or rewrite in the language... cause you can't really determine what the characters are by numbers. So for my art site, I just leave it as the characters in the utf file. But on other sites where I know I won't be changing the text, I convert it to unicode.

meta http-equiv="content-type" content="text/html; charset=utf-8"

unicode converter: http://www.pinyin.info/tools/converter/chars2uninumbers.html
Tehrintehrin on March 13th, 2007 12:16 am (UTC)
edit: I looked at your site, and it won't show up for me either, until I change the character encoding to Utf-8. By default you have it as Western-iso. So use the meta thing I posted above. ^^ That should fix it!
509am on March 13th, 2007 12:17 am (UTC)
Thanks so much Rin!! I didn't know that about the meta-thingy, it works now :D And the converter works great too! Thank you so much :)